WashU IT is investigating an issue with an expired certificate affecting multiple WUSM workstations. A fix has been deployed to make a valid certificate available to affected workstations, but it may take some additional time to fully implement the new certificate. Technical teams will monitor the situation and will provide another update around 2pm on Tuesday, 4/14.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 13, 2026 - 16:33 CDT
Investigating
WashU IT is investigating an issue with an expired certificate affecting multiple WUSM workstations. The main issue being reported is affecting Powershare (Radiology/Cardiology image sharing service), but other services may be impacted as well. A workaround has been successfully implemented for some affected workstations while technical teams continue to troubleshoot the issue.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 13, 2026 - 15:39 CDT
This incident affects: Network & Connectivity (Internet).