Severe Weather Monitoring - 4/27/26

Incident Report for Washington University - IT

Update

1:30 update - All WashU sites are currently up.

We are continuing to monitor for any further issues.
Posted Apr 27, 2026 - 13:30 CDT

Update

We are continuing to monitor for any further issues.
Posted Apr 27, 2026 - 13:00 CDT

Monitoring

WashU IT is monitoring severe weather impact today 4/27/26.

No sites are currently offline.
Posted Apr 27, 2026 - 12:45 CDT
This incident affects: Facilities - Power, Water, Etc.