WashU IT Engineers have resolved the issue affecting external mail and have confirmed that mail delivery is functioning normally. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Apr 14, 2026 - 10:31 CDT
Monitoring
WashU IT identified an issue affecting mail processing queues and implemented a fix. Delivery of external inbound email has been restored and all delayed messages should be available. Technical teams will monitor the environment and will provide another update around 10am.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 14, 2026 - 00:07 CDT
Investigating
WashU IT is investigating reports that inbound email messages from external sources are not being received. Technical teams are working to confirm details and reproduce the issue.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 13, 2026 - 22:33 CDT
This incident affected: Communications & Collaboration (Email, Office 365).