Service Outage: WashU Legacy ECV/FMD URL

Incident Report for Washington University - IT

Postmortem

A post-incident report is now available for this incident.

https://wustl.box.com/s/boudywj1e7j3hohcghfgxixte46u4tpm

Posted Apr 21, 2026 - 10:24 CDT

Resolved

This incident has been resolved.

Users should use the following URL to access services: https://wuapps.wustl.edu/
Posted Apr 19, 2026 - 16:00 CDT

Investigating

WashU IT is aware of an issue with the Legacy ECV/FMD URL.

The new production URL is working and should be used as a permanent workaround. https://wuapps.wustl.edu/

Teams are working to resolve the legacy URL. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 18, 2026 - 21:06 CDT
This incident affected: BJC Devices and Services (BJC Clinical Applications).