Service Degradation: Stale ARCH/SalesForce data in Workday

Incident Report for Washington University - IT

Resolved

The issue with data exports from SalesForce has been resolved.

If you continue to experience further issues, please contact us at 314-933-3333.
Posted Jul 09, 2025 - 13:21 CDT

Investigating

WashU IT is investigating an issue with data exports from ARCH/SalesForce into Workday. Some journal entries may be a day behind until the issue is corrected.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 09, 2025 - 12:17 CDT
This incident affected: Administrative & Enterprise Systems (ARCH - University Advancement SalesForce).