Service Outage: Study Abroad Site Sign-in Unavailable sa.wustl.edu

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issue affecting sign-on from the Study Abroad site. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 29, 2026 - 17:47 CDT

Investigating

WashU IT is investigating an issue with logins not working on sa.wustl.edu, the Study Abroad site. The old SSO solution was retired on Friday 6/26, and a new SSO solution has now been put in place. Technical teams are performing testing to ensure that the site is working properly.

Please call 314-933-3333 if you have any questions.
Posted Jun 29, 2026 - 17:25 CDT
This incident affected: University Websites (WashU IT Hosted Websites).