CampusPress Sites Down From Campus/VPN

Incident Report for Washington University - IT

Resolved

WashU IT Engineers and the CampusPress vendor have resolved the issue affecting some University websites. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 09, 2025 - 10:45 CDT

Investigating

Some WashU sites that are hosted by CampusPress are not available from Campus/VPN. Users are able to access these sites from non-WashU networks.

WashU IT will be working with WashU Marketing and Communications to open a ticket with CampusPress.
Posted Sep 09, 2025 - 07:51 CDT
This incident affected: University Websites (Externally Hosted Websites).