Service

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted May 04, 2026 - 18:14 CDT

Monitoring

WashU IT is aware of an issue that affected receiving email from external parties between 3:55 and 4:10pm.

The issue is resolved and teams are monitoring service health.
Posted May 04, 2026 - 17:19 CDT
This incident affected: Communications & Collaboration (Email).