Service Outage (Vendor) - High Severity: Box Storage Service Outage

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that Box services appear to be restored. The Box vendor has indicated that they have applied a fix and are monitoring to ensure no further issues are observed. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Dec 16, 2025 - 21:44 CST

Investigating

WashU IT is aware that the Box Storage vendor is experiencing service issues, per their status page (https://status.box.com/).

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 16, 2025 - 21:07 CST
This incident affected: Communications & Collaboration (Box File Storage System).