Investigating: Telephony Issues at 4488 Forest Park.

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 09:30 CDT

Monitoring

Phones are recovering by restarting them. Teams are rounding the building to ensure all phones are recovered.

We appreciate your patience during this incident.
Posted Apr 24, 2026 - 07:48 CDT

Investigating

WashU IT is investigating reports of telephony issues at 4488 Forest Park. Some phones are displaying an error message.

Teams are working to resolve the issue. We appreciate your patience as we work to restore service.
Posted Apr 24, 2026 - 07:32 CDT
This incident affected: Network & Connectivity (Phone).