WashU IT Engineers monitored Workday throughout the day today and did not observe further issues. Workday is operating normally. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Nov 03, 2025 - 19:26 CST
Investigating
WashU IT is investigating internal reports that Workday is running slowly (no user calls at this time). Based on previous years, some performance degradation is normal during open enrollment for benefits. Technical teams will continue to monitor the environment and will consider sending end user communication if the Service Desk starts receiving calls on the issue.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 03, 2025 - 10:21 CST
This incident affected: Administrative & Enterprise Systems (Workday).