Epic Unavailable for some clients

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the inability of a small number of clients to access Epic by manually completing the upgrade installations. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 05, 2026 - 10:25 CST

Investigating

WashU IT has received reports that Epic is unavailable for some clients. We are investigating the issue.
Posted Mar 05, 2026 - 08:31 CST
This incident affected: Clinical Applications (EPIC).