Service Outage (Vendor): Microsoft Outlook and Teams

Incident Report for Washington University - IT

Resolved

Microsoft has resolved the issue with Outlook.

If you continue to experience further issues, please contact us at 314-933-3333.
Posted Jul 10, 2025 - 16:30 CDT

Monitoring

Microsoft has introduced a possible fix for the issues. Teams are continuing to monitoring the service.

If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jul 10, 2025 - 15:32 CDT

Update

WashU IT is investigating reported issues with Microsoft Outlook and Microsoft Teams. Microsoft believes that the fix they implemented has deployed to most customers and that service has been mostly restored. They continue to monitor their environment in case of additional issues. Please refer to their status page for additional details: https://portal.office.com/servicestatus/

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 10, 2025 - 13:45 CDT

Identified

WashU IT is investigating reported issues with Microsoft Outlook and Microsoft Teams. Microsoft has deployed an update to impacted users and is monitoring the environment to identify any additional issues. Please refer to their status page for additional details: https://portal.office.com/servicestatus/

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 10, 2025 - 11:50 CDT

Update

We are continuing to investigate this issue.
Posted Jul 10, 2025 - 10:16 CDT

Investigating

WashU IT is investigating reported issues with Microsoft Outlook and Microsoft Teams. Microsoft has acknowledged a service outage and is working to resolve the problem. Please refer to their status page for additional details: https://portal.office.com/servicestatus/

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 10, 2025 - 10:13 CDT
This incident affected: Communications & Collaboration (Email, Office 365, Microsoft Teams).