Microsoft Vended Outage - BJC Email, Teams

Incident Report for Washington University - IT

Resolved

Microsoft has resolved the issue with vended services.

More information can be found at https://status.cloud.microsoft/ .
Posted Oct 09, 2025 - 14:46 CDT

Monitoring

WashU IT is aware of Microsoft issues affecting BJC Teams and Outlook.

WashU teams are currently evaluating service health to determine if there is WashU impact.
Posted Oct 09, 2025 - 14:07 CDT
This incident affected: Communications & Collaboration (Office 365, Microsoft Teams).