Box Storage support has posted a notification on their status page that they had a brief service interruption, which has now been resolved. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Mar 18, 2026 - 13:54 CDT
Investigating
WashU IT is investigating reports of service issues with Box Storage. Users are reporting slow performance or are otherwise unable to open some files or view previews. Box has not posted an initial acknowledgement of the issue, but online indicators show that other customers are also reporting difficulties. Technical teams are opening a support ticket with the vendor.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 18, 2026 - 13:49 CDT
This incident affected: Communications & Collaboration (Box File Storage System).