Vendor Service Outage: GrubHub

Incident Report for Washington University - IT

Resolved

GrubHub Campus has indicated that all services are back at operational baseline with all systems healthy. 

Mobile orders are working as expected.
Posted Apr 13, 2026 - 18:07 CDT

Update

Dining Services is in contact with the GrubHub vendor who is aware of the issue and working to restore service.

Food services are still available through traditional walk-up kiosks.
Posted Apr 13, 2026 - 16:40 CDT

Identified

Washington University IT is aware of a vendor issue affecting GrubHub customers.

The vendor is working to working to resolve the issue.

We appreciate your patience as we work to restore service.
Posted Apr 13, 2026 - 16:02 CDT
This incident affected: Vendor Service.