WashU IT is investigating an issue with some students reporting that they cannot access their Papercut funds. Technical teams are taking the necessary steps to manually restore the expected balance of funds to affected students. We will continue to monitor the situation overnight and will reconvene on Tuesday morning to do a final status check before closing the MI.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 12, 2026 - 18:18 CST
Update
WashU IT is investigating an issue with some students reporting that they cannot access their Papercut funds. The issue is related to workflow with Workday and the students' move-in date, and is expected to be resolved automatically within the next 48 hours. In the interim, if students try to print it will deduct the cost from their Bear Bucks account.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 12, 2026 - 16:42 CST
Investigating
WashU IT is investigating an issue with some students reporting that they cannot access their Papercut funds.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 12, 2026 - 15:22 CST
This incident affects: Computing and Printing (PaperCut Printing).