WashU IT and BJC IT Engineers have successfully resolved the issue affecting Epic and Midmark EKG. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Dec 17, 2025 - 18:40 CST
Identified
WashU IT is investigating an issue with the Midmark EKG application not loading from within Citrix at multiple locations (primarily West County MOB3). Users can launch the application locally on the device, but printing and other features are unavailable. BJC and WashU IT teams working with the vendor have identified at least part of the root cause and are in the process of applying a fix.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 17, 2025 - 17:12 CST
Update
WashU IT is investigating an issue with the Midmark EKG application not loading from within Citrix at multiple locations (primarily West County MOB3). Users can launch the application locally on the device, but printing and other features are unavailable. BJC and WashU IT teams are working together to troubleshoot and have reached out to the vendor for assistance.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 17, 2025 - 15:23 CST
Investigating
WashU IT is investigating an issue with the Midmark EKG application not loading from within Citrix at multiple locations (primarily West County MOB3). Users can launch the application locally on the device, but printing and other features are unavailable.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 17, 2025 - 14:03 CST
This incident affected: BJC Devices and Services (BJC Clinical Applications).