WashU IT will continue to monitor the MECM instance after a change to service account permissions to prevent a recurrence that is planned for this evening. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted May 11, 2026 - 16:35 CDT
Monitoring
WashU IT has introduced a possible fix for the MECM outage that was affecting Windows imaging and Software Center by rebooting a non-responsive server Teams are continuing to monitoring the service. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted May 11, 2026 - 09:09 CDT
Investigating
WashU IT is investigating an issue with MECM and Software Center. Imaging of Windows systems and Software Center functionality are impacted.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 11, 2026 - 08:58 CDT
This incident affects: Computing and Printing (Desktop Computing).