Service Outage - High Severity: Network Unavailable @ 955 Executive Parkway

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issues affecting network availability at this site. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 06, 2026 - 15:21 CST

Investigating

WashU IT is investigating an issue with network connectivity at 955 Executive Parkway. Technical teams are opening a support call with the vendor.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 06, 2026 - 12:58 CST
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).