Vendor Service Degradation: Emma

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that the vendor has restored service to Emma. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Oct 01, 2025 - 13:04 CDT

Identified

Marigold, the Emma vendor, has announced slow performance impacting the Emma web application.

Pages may load slowly when working within Emma.

Detailed information can be found at https://status.myemma.com/
Posted Oct 01, 2025 - 10:35 CDT
This incident affected: Communications & Collaboration (Emma).