Service Outage (Vendor) - Low Severity: Microsoft Azure Portal

Incident Report for Washington University - IT

Resolved

Microsoft has resolved the issue affecting Azure portal service. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Oct 09, 2025 - 20:10 CDT

Update

WashU IT has received reports that the Microsoft Azure portal is either unavailable or content within the portal is inaccessible. Microsoft is monitoring the stability of their Azure platform and is still working to fully restore service. Please see the Azure status page for more information: https://azure.status.microsoft/en-us/status
Posted Oct 09, 2025 - 19:21 CDT

Update

WashU IT has received reports that the Microsoft Azure portal is either unavailable or content within the portal is inaccessible. Microsoft has taken steps to mitigate the issue and is monitoring their environment to ensure a successful update to their customers. Please see the Azure status page for more information: https://azure.status.microsoft/en-us/status
Posted Oct 09, 2025 - 17:57 CDT

Investigating

WashU IT has received reports that the Microsoft Azure portal is either unavailable or content within the portal is inaccessible. Microsoft has acknowledged a service issue on their side which is affecting multiple customers. End user impact to WashU users is minimal; the main impact is to WashU IT teams who cannot get into the portal to manage settings and integrations. Please see the Azure status page for more information: https://azure.status.microsoft/en-us/status

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Oct 09, 2025 - 16:15 CDT
This incident affected: Vendor Service.