Service Outage - High Severity: Microsoft 365 Service Outage

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have identified the issue affecting connectivity to some Microsoft 365 services as a security block on a firewall. We have manually bypassed that block to allow traffic to the affected services. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 06, 2026 - 09:16 CST

Investigating

WashU IT is investigating potential service issues with Microsoft 365 services, including Sharepoint. Technical teams are opening a support ticket with Microsoft for further assistance.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 06, 2026 - 08:30 CST
This incident affected: Communications & Collaboration (Office 365).