Service Outage - High Severity: Imprivata Login Issues

Incident Report for Washington University - IT

Resolved

WashU and BJC IT Teams identified and resolved the issues affecting Imprivata login. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 03, 2026 - 10:40 CDT

Investigating

WashU IT is investigating an issue with Imprivata badge logins issues at multiple clinic locations. When someone logs out, the screen to log back in is very slow to appear, and logging in also takes a long time to process.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 03, 2026 - 09:12 CDT
This incident affected: Clinical Applications (ECV (Enterprise Client Virtualization)).