Haiku Access for Some Residents and Trainees

Incident Report for Washington University - IT

Resolved

WashU IT networking team performed a change on Feb. 26th related to the symptoms experienced with this issue. After valdiating with customers, this problem is now resolved.
Posted Mar 03, 2026 - 09:22 CST

Update

We are continuing to monitor for any further issues.
Posted Mar 03, 2026 - 09:20 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 10:11 CST

Update

Teams are working to identify affected customers to reproduce the issue and understand the conditions in which the issue might occur.
Posted Feb 24, 2026 - 07:31 CST

Investigating

WashU IT is aware of reports of some residents and trainees being unable to connect to Haiku when on WiFi.

WashU is working with BJC and Epic teams to investigate the reports.
Posted Feb 23, 2026 - 11:17 CST
This incident affected: BJC Devices and Services (BJC Clinical Applications).