Service Outage - Low Severity: Network Unavailable @ 22 N. Euclid

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that Spectrum restored service to the 22 N. Euclid site. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 12, 2025 - 09:52 CDT

Update

WashU IT is investigating an issue with network connectivity at the 22 N. Euclid site. Spectrum is still running diagnostics and has engaged additional engineering resources towards repairing the damaged fiber. No ETR has been provided by Spectrum at this time; we will post another update on Saturday morning ~9am.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 11, 2025 - 22:02 CDT

Update

WashU IT is investigating an issue with network connectivity at the 22 N. Euclid site. Spectrum is still running diagnostics and has engaged additional engineering resources towards repairing the damaged fiber.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 11, 2025 - 18:56 CDT

Identified

WashU IT is investigating an issue with network connectivity at the 22 N. Euclid site. Spectrum has identified a fiber cut causing a service outage and is engaging repair technicians to go on-site.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 11, 2025 - 15:55 CDT

Investigating

WashU IT is investigating an issue with network connectivity at the 22 N. Euclid site. Network team has someone on-site; troubleshooting has been unsuccessful, so a support ticket has been opened with Spectrum to come out and investigate further.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 11, 2025 - 14:02 CDT
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).