WashU IT Engineers have confirmed that the vendor has restored Kaltura and Canvas services. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted May 04, 2026 - 09:47 CDT
Update
WashU IT is investigating an issue with the Kaltura integration with Canvas. Kaltura is one of our systems for video storage and presentation (ex: lecture recordings) and is especially important while students are preparing for final exams. Canvas has identified a service issue on their end. Additional details are available here: https://status.instructure.com/.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 03, 2026 - 11:05 CDT
Update
WashU IT is investigating an issue with the Kaltura integration with Canvas. Kaltura is one of our systems for video storage and presentation (ex: lecture recordings) and is especially important while students are preparing for final exams. Canvas has identified a service issue on their end. Additional details are available here: https://status.instructure.com/.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 02, 2026 - 11:39 CDT
Update
WashU IT is investigating an issue with the Kaltura integration with Canvas. Kaltura is one of our systems for video storage and presentation (ex: lecture recordings) and is especially important while students are preparing for final exams. Canvas has identified a service issue on their end. Additional details are available here: https://status.instructure.com/.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 01, 2026 - 17:15 CDT
Update
WashU IT is investigating an issue with the Kaltura integration with Canvas. Kaltura is one of our systems for video storage and presentation (ex: lecture recordings) and is especially important while students are preparing for final exams. Canvas has identified a service issue on their end. Additional details are available here: https://status.instructure.com/
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 01, 2026 - 15:31 CDT
Update
WashU IT is investigating an issue with the Kaltura integration with Canvas. Kaltura is one of our systems for video storage and presentation (ex: lecture recordings) and is especially important while students are preparing for final exams. Canvas has identified a service issue on their end. Additional details are available here: https://status.instructure.com/
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 01, 2026 - 13:16 CDT
Update
WashU IT is investigating an issue with the Kaltura integration with Canvas. Kaltura is one of our systems for video storage and presentation (ex: lecture recordings) and is especially important while students are preparing for final exams. Technical teams are working with our vendors to identify and resolve the root cause.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 01, 2026 - 11:46 CDT
Investigating
WashU IT is investigating an issue with the Kaltura integration with Canvas. Kaltura is one of our systems for video storage and presentation (ex: lecture recordings) and is especially important while students are preparing for final exams. Technical teams are opening support tickets with our Canvas and Kaltura vendors for assistance.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 01, 2026 - 09:39 CDT
This incident affected: Teaching & Learning (Canvas, Kaltura).