Service Outage (Vendor) - Low Severity: SFax not allowing users to log in

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 14:39 CST

Investigating

WashU IT is investigating an issue with SFax not allowing users to log in so they can send outbound faxes. Inbound faxes are not affected. The vendor has acknowledged a service outage and is working to resolve the issue.

Please call 314-933-3333 if you have any questions.
Posted Dec 09, 2025 - 10:32 CST
This incident affected: Clinical Applications (S-Fax).