WashU IT Engineers have resolved the issue affecting RMS data. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Dec 15, 2025 - 23:04 CST
Update
WashU IT is investigating an issue with stale data in RMS, believed to be due to an issue with integration from Workday. A fix was deployed to the Production environment and was partially successful in resolving the issue. Technical teams will resume troubleshooting on Tuesday morning.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 15, 2025 - 22:07 CST
Update
WashU IT is investigating an issue with stale data in RMS, believed to be due to an issue with integration from Workday. A fix has been successfully implemented in the Test environment and is currently being deployed into Production.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 15, 2025 - 21:03 CST
Identified
WashU IT is investigating an issue with stale data in RMS, believed to be due to an issue with integration into Workday. End users are currently only seeing data through EOD Thursday 12/11/25. After a support call with our vendor, technical engineers have implemented a potential fix in the test environment and are waiting to confirm if the issue is resolved.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 15, 2025 - 18:18 CST
Investigating
WashU IT is investigating an issue with stale data in RMS, believed to be due to an issue with integration into Workday. End users are currently only seeing data through EOD Thursday 12/11/25.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Dec 15, 2025 - 15:03 CST
This incident affected: Research (RMS (Research Management System)).