Service Outage (Vendor) - Low Severity: Mac Self-Service Portal (Jamf)

Incident Report for Washington University - IT

Resolved

The Jamf vendor has restored service to some customers and is still working to fully restore service across all affected platforms. WashU IT Engineers have verified that our Jamf service is functioning normally. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 15, 2025 - 19:25 CDT

Identified

WashU IT has received notification from the Jamf vendor that they are experiencing a service outage affecting multiple customers. This impacts WashU Mac computer users and may result in them being unable to use the software self-service portal. The vendor has identified the root cause and is working to develop a fix. Please refer to the vendor's Status Page for more details: https://status.jamf.com/.

Please call 314-933-3333 if you have any questions.
Posted Apr 15, 2025 - 17:32 CDT

Investigating

WashU IT has received notification from the Jamf vendor that they are experiencing a service outage affecting multiple customers. This impacts WashU Mac computer users and may result in them being unable to use the software self-service portal. Please refer to the vendor's Status Page for more details: https://status.jamf.com/.

Please call 314-933-3333 if you have any questions.
Posted Apr 15, 2025 - 16:33 CDT
This incident affected: IT Infrastructure Components (JAMF Apple Device Management System).